Getting Starting
Image Preprocessing
Color Reduction - Change Palette
Spots Removal
Image Segmentation
Edge Detection
General Vectorizing Options
Advanced Vectorizing Options
Vector Editor Settings
View Settings
Vector Formats
Coordinate Reference
Menu and Commands
File Menu
Edit Menu
Raster Menu
Vector Menu
View Menu
Window Menu
Command Line
How to Register
User Support

Vextractor Online Help
Prev Page Next Page

Coordinate referencing

Coordinate referencing is required for setting a coordinates system that is different than the raster coordinate system. It may be necessary for processing raster images typical for CAD or GIS systems - drafts, maps, schemes, etc. The program has the following four reference methods in stock:

  1. Setting vector area sizes.
  2. By control points.
  3. By GeoTIFF conversion coefficients.
  4. By World-files coefficients.

Information on current image reference is available through the Vector|Coordinate Reference Info menu.

Setting vector area sizes

In this mode, you can set size and units for a vector image.

Control-points reference

Referencing coordinates by control points means assigning certain raster points (pixels) real coordinates in a required coordinate system. It is common to select points with known coordinates: intersections of gridlines on maps, building corners on architect plans, coordinate axes on charts, etc.

How many such points should one set? Theoretically, the more - the better, within a reasonable range. Setting just one point will set the point of origin in the new coordinates system. If your image is properly oriented originally, one point may be enough. Two points set rotation angle and scale (equal on the X and Y axes). Three points that do not belong to the same line set the offset, rotation, and individual scaling by axes. The greater the number of points adjusts conversion ratios and may help you reduce some raster distortions. Such distortions often occur with documents scanned off the hardcopy.

You can set points of reference through the menu Vector|Set Coordinate Reference Points or through the corresponding button on the toolbar. After you have switched to the reference mode, you can point the reference mode by clicking on it with the mouse. This will open the dialog with zoomed-in image of the selected area. Use that image to fine-tune the point of reference and set the actual coordinates:

Notes on referencing images with raster resolution data (dpi)

If an image carries raster resolution data (see Raster|Image Info), and the vector units are set in inches, meters, centimeters or millimeters - that will affect the vector coordinate values. Vectorized objects will have sizes and ratios of those on the hard copy. This will take effect if you do not set a custom coordinate system with two or more points of reference. Referencing just one point will preserve the original image's size and ratios.

The CHM file was converted to HTML by chm2web software.