Getting Starting
Image Preprocessing
Color Reduction - Change Palette
Spots Removal
Image Segmentation
Edge Detection
General Vectorizing Options
Advanced Vectorizing Options
Vector Editor Settings
View Settings
Vector Formats
Coordinate Reference
Menu and Commands
File Menu
Edit Menu
Raster Menu
Vector Menu
View Menu
Window Menu
Command Line
How to Register
User Support

Vextractor Online Help
Prev Page Next Page

Edit menu commands


Cancels the last action. The command cancels both operations over vector objects and manipulations over raster image.

Create Polyline

Creates a polyline. Use mouse to set points.

Create Spline Polyline

Creates a spline polyline based on Bezier curves. Use mouse to set points.

Create Circle

Creates circle. Set the circle's center and then set a point on the circle's radius.

Create Arc

Creates an arc. Set the following three points to draw an arc: arc beginning and end, and a point on the arc.

Edit Object

Edit vector object in the "exclusive" mode. In the exclusive mode, all editing tools are applied to the selected object only. To exit from the exclusive mode, right-click over the edit area and then select End edit on the context menu that appears. Or - simply hit Escape.

Delete Object

Deletes the selected object. In the exclusive mode, this action only deletes the currently selected object. In the regular mode, you can use this action to delete any objects you select with the mouse.

Edit User Data

Edits text data related to some object. Currently, you can set a text string as a contour attribute.

Move Point

Moves an edited object's points. This action is applicable to all vector object types the program supports: polylines, arcs, and circles. While you are selecting the point to be moved, the program will highlight the point that is closest to the cursor. Clicking on the highlighted point will lock your selection, and dragging the "grabbed" point will set its new position.

Insert Point

Inserts a point to a polyline segment. First, select the polyline segment to insert a point to. While you are selecting the segment, the program will highlight the points that are closest to the cursor. To lock your selection, click on the highlighted point. Click once again to set the position to insert the point to.

Delete Point

Deletes polyline's current point. The selected point will be highlighted with the marker. You can also delete the current point by pressing the "Delete" key on your keyboard.

Delete Segment

Deletes a polyline's segment.  The selected segment is highlighted. Clicking on the segment deletes it.

Note: Deleting a segment from a closed polyline automatically opens it. For more information, please see the Close Polyline command.

Add Point to End

Adds a point to a polyline's end. Before adding a point, you need to select the end to add the point to, so the program switches to the end-selection mode right when you activate the command. During the selection, the "rubber" line will show the closest end. A mouse click will lock the selection of the closest end. Following mouse clicks will add points to the end.

Split Polyline

Splits a polyline. If a polyline has at least two segments, you can split it. In the general edit mode, select the vertex (red marker), and the polyline will split into two portions after you have clicked on it. Everything is a bit more complicated in the exclusive mode. The splitting process takes two steps. The first step is selecting the vertex, just like in the general mode. The second step is selecting the polyline's segment to be edited. The selected segment remains active for editing in the exclusive mode.

Close Polyline

Closes a polyline. If the first point and the last point are not the same, a new point with the polyline's first point coordinates is added to the end of the polyline. Closed polylines maintain their properties (matching first and last points)  when points are moved. The first and the last points are moved jointly, without opening the contour. The following commands are available for closed polylines:

  • Add Point to End
  • Merge Polylines

To open a polyline, you can either use the Split Polyline command or simply delete any segment of the polyline by selecting the Delete Segment command.

Merge Polylines

Merging polylines is the most complicated procedure: to properly merge polylines, you will need to select one of the first polyline's ends and the second polyline's corresponding end. The program will highlight the polyline's closest end and the segment that is common for both of the contours during selection. The first mouse click will lock the selection of the first polyline (the closest end will be selected). Selecting the second end is pretty much the same; it will complete the merging.

All edit commands are performed in cycles. It is supposed that you are going to perform series of a point moves, deletions, insertions, etc. If you need to leave the edit mode, you can either switch to a different mode or cancel editing by hitting Esc - or - select the corresponding item on the context menu (right-click to open the menu). In some cases, you may need to press Esc twice. For example, in the exclusive mode, the first click will close the current edit mode (if it is selected), and the second click will complete the editing.

Select Objects

Selects objects. Selected objects will be highlighted in red (by default; for more information, please refer to View|View Settings). The second selection of the object cancels selection. You can select several objects at the same time, which fall within the selection rectangle boundaries. To set the selection rectangle, click on the area to be selected and then drag the mouse pointer while holding the mouse button down.

Invert Selection

Inverts objects selection.

Deselect All

Removes selection from all selected objects.

Delete Selected Objects

Deletes selected objects.

View Selection Info

Displays text information on selected objects.

The CHM file was converted to HTML by chm2web software.