Getting Starting
Image Preprocessing
Color Reduction - Change Palette
Spots Removal
Image Segmentation
Edge Detection
General Vectorizing Options
Advanced Vectorizing Options
Vector Editor Settings
View Settings
Vector Formats
Coordinate Reference
Menu and Commands
File Menu
Edit Menu
Raster Menu
Vector Menu
View Menu
Window Menu
Command Line
How to Register
User Support

Vextractor Online Help
Prev Page Next Page

File menu commands

Open Raster

Opens raster images of the following formats:

  • BMP
  • GIF
  • JPEG
  • TGA 
  • PCX
  • RAS
  • WBMP
  • ICO 

Vectorization is only available for black-and-white and palette images of up to 256 colors. Images with greater color depth (e.g., 24 bpp TrueColor) must be converted to black-and-white with the Raster|Change Palette command.

Save Raster As

Saves raster images. The program supports the following output formats:

  • BMP
  • TIFF
  • PNG


Closes current raster.

Select TWAIN32 Source

Selects TWAIN32-compatible image source (scanner).

TWAIN32 Acquire

Launches scanning image with selected scanner.

Save Vector As

Saves vector data to file. More...

The program supports the following file formats:

  • AutoCAD DXF
  • AutoCAD DXB
  • ArcView Shapefiles
  • MapInfo MID/MIF
  • Windows Metafile (WMF)
  • Windows Enhanced Metafile (EMF)
  • Scalable Vector Graphic (SVG)
  • Encapsulated PostScript (EPS)
  • Adobe Illustrator (AI)

Save Selected Vectors As

Saves only the vector objects that have been selected with the Edit|Select Object command.

Backup to VFF

Saves vectors to internal format. "VFF" stands for "Vextractor File Format". This format is used for storing vector data between sessions. The VFF file name is the same as the raster file name; this allows you to link the raster and vector images. When you open a raster file, the program will search for and then open the corresponding VFF file (if it exists). The VFF file is created in the same folder with the raster file. The search will be also limited with the folder where the raster file resides. You can manage creation of the VFF file via the Edit|Edit Options menu.

Open Coordinate Reference

Opens a point-of-reference file (*.grp) or World-file with reference coefficients. The World-file's extension depends on the raster file type; the program generates it as follows: it takes the raster extension's first and last letter and then appends "w". 


  1. Image file: image.tif - reference file: image.tfw
  2. Image file: image.bmp - reference file: image.bpw

Save Coordinate Reference As

Saves current coordinate reference as:

  1. File with the *.grp (Geo Reference Points) extension.
  2. World-files (*.tfw, *bpw, etc.)

A grp-file is a plain-text file that contains records of this type:

Raster_X  Raster_Y  World_X  World_Y

These records set correspondence between an image's raster coordinates system and the world coordinates system.


0 0 1000.0 1000.0
0 1000 1000.0 2000.0
1000 0 2000.0 1000.0

Batch Processing

Batch- processes multiple raster images with no interaction with user.


Closes the application.

The CHM file was converted to HTML by chm2web software.