Getting Starting
Image Preprocessing
Color Reduction - Change Palette
Spots Removal
Image Segmentation
Edge Detection
General Vectorizing Options
Advanced Vectorizing Options
Vector Editor Settings
View Settings
Vector Formats
Coordinate Reference
Menu and Commands
File Menu
Edit Menu
Raster Menu
Vector Menu
View Menu
Window Menu
Command Line
How to Register
User Support

Vextractor Online Help
Prev Page Next Page

Getting started

How to obtain the image

To vectorize an image, you must have the raster file in one of the following formats: 

  • BMP
  • GIF
  • JPEG
  • TGA
  • PCX
  • RAS
  • WBMP
  • ICO

To open the raster image file, please select the File|Open Raster menu.

You may use scanner to acquire an image from a hardcopy (paper) directly. The program supports TWAIN32-compatible scanners. Use the File|Select TWAIN32 source menu to select the scanner; to actually scan an image, select the File|TWAIN32 Acquire command.

Preparing image for vectorization

Since the current version of the program supports only black-and-white or up-to 256-color palette images, all RGB TrueColor must be converted to palette images. For that purpose, you can use the Raster|Change Palette command.

Enhancing image

The majority of scanned images come with all kinds of defects; e.g. stains, "scratches", etc. Vextractor carries a number of filters for removing such defects:

  • Raster|Despeckle
  • Raster|Remove Isolated Objects
  • Raster|Median
  • Raster|Erode/Dilate/Opening/Closing


To start vectorization, select the Vector|Start Vectorizing command on the menu or click the corresponding button on the toolbar. After the process is complete, the vector data will be displayed over the raster. By selecting the Edit|Select object command on the menu you can select individual objects for closer viewing. You can also adjust vectorization settings with the Vector|Options command.

Editing vector objects

You can make additional changes to objects the program has generated . All editing commands are available through the Edit menu or the corresponding button on the toolbar.

Saving vectorization results

You can save vectorized image in the following formats:

  • AutoCAD DXF
  • AutoCAD DXB
  • ArcView Shapefiles
  • MapInfo MID/MIF
  • Windows Metafile (WMF)
  • Windows Enhanced Metafile (EMF)
  • Scaleble Vector Graphic (SVG)
  • Encapsulated PostScript (EPS)
  • Adobe Illustator (AI)

Note: the demo version of the program has some restrictions for size of data being saved and adds "watermarks" to the vector image.

The CHM file was converted to HTML by chm2web software.