Getting Starting
Image Preprocessing
Color Reduction - Change Palette
Spots Removal
Image Segmentation
Edge Detection
General Vectorizing Options
Advanced Vectorizing Options
Vector Editor Settings
View Settings
Vector Formats
Coordinate Reference
Menu and Commands
File Menu
Edit Menu
Raster Menu
Vector Menu
View Menu
Window Menu
Command Line
How to Register
User Support

Vextractor Online Help
Prev Page Next Page


Vextractor is a tool for converting raster images to vector by drawing centerlines and outlines. Vextractor can be used for vectorizing drafts, maps, schemes, logos, charts, etc.

The program's basic features:

The following two vectorization methods are available:

  • Drawing centerlines (skeleton lines) over raster.
  • Drawing contours of area boundaries.

The following two line smoothing methods are available:

  • Piecewise-linear approximation (polyline creation).
  • Spline approximation by Bezier curves.

The following options are available for drawing centerlines:

  • Arc and circle recognition.
  • Orthogonal lines recognition.
  • Automatic filling of line gaps.
  • Automatic tracing of contours through line intersections.

The program supports the following raster formats:

  • BMP
  • GIF
  • JPG
  • PNG
  • TGA
  • RAS
  • PCX
  • WBMP
  • ICO

The output vector data can be saved in the following formats:

  • AutoCAD DXF
  • AutoCAD DXB
  • ArcView Shape files (SHP)
  • MapInfo MID/MIF
  • Windows Metafile (WMF)
  • Windows Enhanced Metafile (EMF)
  • ASCII XYZ (Plain text)
  • Scalable Vector Graphic (SVG)
  • Encapsulated PostScript (EPS)
  • Adobe Illustrator (AI)

The following tools are available for correcting raster images:

  • 90º-divisible rotation.
  • Custom-degree rotation.
  • Horizontal and vertical mirroring.
  • Inversion.
  • Adjusting brightness and contrast.
  • Adjusting image palette.
  • Median filtering.
  • Removing isolated black and white areas (for binary images only).
  • Noise filtering by averaging with threshold (for binary images only).
  • Morphological operations: Opening, Closing, Erode, Dilate.

The results of such processing can be saved in the following raster formats:

  • BMP
  • TIFF
  • PNG

Supports TWAIN32-compatible scanners.

Built-in vector editor. Allows editing contours, arcs, and circles generated during vectorization and creating vector objects manually.

Coordinate referencing of images. Supports referencing data contained in the GeoTIFF and World-files. Allows two referencing methods:

  • By image size.
  • By setting a point of reference.

Batch processing (vectorization).

The CHM file was converted to HTML by chm2web software.